Math 123 (Introduction to Statistics)
SPSS Lab Exercise #4
In this lab, you will

          (
enter a contingency table into an SPSS data file
          (
create a pie chart from a contingency table
          (
create a stacked bar chart from a contingency table
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To do this lab, you will need a copy of the data displayed as a contingency table for Text Exercise 8-2 (i.e., Table 8-4 in the textbook) in Exercise Set 8; for convenience, this table is displayed here on the right.
1. Enter the contingency table into an SPSS data file named jobs; print a copy of the data; and write your name, your section, today’s date, and the lab number on the printed copy.

Step 1:

Enter SPSS (as described in Lab Exercise #0), and begin with a blank data window on the screen.  In order to enter two variable names, go to the Variable View sheet by clicking on the appropriate tab at the bottom of the screen.

Step 2:

In the first cell of the Name column in the Variable View sheet, type smoke, which shall be our abbreviated name for the row variable of the contingency table.  In the second cell of the Name column, type jobtype, which shall be our abbreviated name for the column variable of the contingency table.

Step 3:

Notice that, after entering the new variable names, a lot of default settings appear in many of the other columns.  The Label column allows you to enter a longer name for a variable, if you wish, because the abbreviated name in the Name column is not allowed to be more than eight characters.  In the Label column for the variable smoke, type Smoking Habits, and in the Label column for the variable jobtype, type Job Type.

Step 4:

In the row for the variable smoke, click on the cell in the Values column, and click on the button which appears in the right hand side of the cell to display the Value Labels dialog box.  In the Value slot type a 1 (one), and in the Label slot type the label Nonsmoker.  Then click on the Add button, and observe that 1.00="Nonsmoker" appears in the section at the bottom of the dialog box.  Similarly, define codes so that 2.00="Light Smoker" and 3.00="Heavy Smoker" also appear in the section at the bottom of the dialog box.  Click on the OK button to leave the dialog box.

Step 5:

Click on the cell in the Values column in the row for the variable jobtype, and click on the button which appears in the right hand side of the cell to display the Value Labels dialog box.  Define codes so that 1.00="Secretary", 2.00="Salesman", and 3.00="Executive" appear in the section at the bottom of the dialog box.  Click on the OK button to leave the dialog box; then return to the Data View sheet.

Step 6:

In the first row of the blank Data View sheet, type a 1 (one) in the smoke column, and type a 1 (one) in the jobtype column.  (If you do not now see that the labels Nonsmoker and Secretary appear, then select View> Value Labels from the main menu.)
Step 7:

In the second row of the Data View sheet, type a 1 (one) in the smoke column, and type a 2 (two) in the jobtype column.

Step 8:

In the third row, type a 1 (one) in the smoke column, and type a 3 (three) in the jobtype column.

Step 9:

In the fourth row, type a 2 (two) in the smoke column, and type a 1 (one) in the jobtype column.

Step 10:

In the fifth row, type a 2 (two) in the smoke column, and type a 2 (two) in the jobtype column.

Step 11:

In the sixth row, type a 2 (two) in the smoke column, and type a 3 (three) in the jobtype column.

Step 12:

In the seventh row, type a 3 (three) in the smoke column, and type a 1 (one) in the jobtype column.

Step 13:

In the eighth row, type a 3 (three) in the smoke column, and type a 2 (two) in the jobtype column.

Step 14:

In the ninth row, type a 3 (three) in the smoke column, and type a 3 (three) in the jobtype column.

Step 15:

You should now see that the first nine rows of the Data View sheet display all nine possible combinations of categories for the row variable (smoke) and column variable (jobtype) in the contingency table.  (You can change the column width(s), if any of the category names do not display completely.)  In the third column of the Data View sheet, enter the frequencies from the contingency table which correspond to the combinations in the first and second columns.  (For example, in the fifth row of the Data View sheet, which corresponds to a light smoker and salesman, you will type 26; in the seventh row, which corresponds to a heavy smoker and secretary, you will type 35.)
Step 16:

To name this new variable in the third column of the data sheet, return to the Variable View sheet, and in the third cell of the Name column, type freq, which shall be our abbreviated name for frequencies.  Change the entry in the third cell of the Decimals column to 0 (zero), since all the frequencies must be integers.  Return to the Data View sheet.

Step 17:

Save the data file with the name jobs in your personal folder on the network (making certain that you access the proper folder).

Step 18:

Print a copy of the data by selecting File> Print from the main menu in the Data View sheet.  At the top of the printout, write a title in the following format:

Your Name - Math 123(your section) - Today's Date - Lab #4
2. Create a pie chart to display the distribution of the variable smoking habits (smoke), and print a copy of the pie chart.

Step 1:

Before using this data file, we must first indicate that the number of times to count each of the nine lines is equal to the frequencies stored in the variable freq.  To do this, select the Data> Weight Cases options to display the Weight Cases dialog box.
Step 2:

In the Weight Cases dialog box, select the Weight cases by option.  Select the variable name freq from the list on the left, and click on the arrow button pointing toward the Frequency Variable slot of the dialog box.  Click on the OK button.
Step 3:

Select the Graphs> Legacy Dialogs> Pie options to display the Pie Charts dialog box.
Step 4:

In the Pie Charts dialog box, make certain that the option Summaries for groups of cases has been selected.  Then, click on the Define button to display the Define Pie: Summaries for Groups of Cases dialog box.
Step 5:

In the Define Pie: Summaries for Groups of Cases dialog box, you should see a list of the variables on the left.  Select Smoking Habits (smoke), and click on the arrow button pointing toward the Define Slices by slot of the dialog box.  Make certain that the option N of cases has been selected in the Slices Represent section of the dialog box.  Click on the OK button, after which the graph is displayed as SPSS output.
Step 6:

Notice that the title of the output is Graph.  Double click on this title to edit it, so that it is in the following format:

Pie Chart for Smoking Habits - Text Exercise 8-2

Your Name - Math 123(your section) - Today's Date - Lab #4
When you are finished editing the title, click once in a blank area to leave the title editor.
Step 7:

Double click on the graph in order to display the graph in the SPSS Chart Editor where a graph can be customized.
Step 8:

In the SPSS Chart Editor, select from the main menu the Elements> Show Data Labels options to display the Properties dialog box.
Step 9:

In the Properties dialog box, select the Data Value Labels tab.  Use the arrow keys on the right to make certain that Count, Percent, and smoke are all listed in the Displayed section.  Click on the Apply button to update the graph; then, click on the Close button.
Step 10:

From the menu, select the Options> Hide Legend options; then select the File> Close options to close the chart editor.
Step 11:

You may delete each one of text boxes containing a log of the SPSS procedures used, by clicking once to select and pressing the delete key once.  Then, make certain that no item in the output is selected, and use the File> Print options to obtain a printed copy of the pie chart.
Step 12:

Since there is no need for you to save the output, you may close the SPSS output window without saving the results, after you have your printed copy of the output.
3. Create a contingency table with row and column totals, and with row and column percentages; print a copy of the contingency table.

Step 1:

Select the Analyze> Descriptive Statistics> Crosstabs options to display the Crosstabs dialog box.
Step 2:

In the Crosstabs dialog box, you should see a list of the variables on the left.  Select Smoking Habits (smoke), and click on the arrow button pointing toward the Row(s) slot of the dialog box; then select Job Type (jobtype), and click on the arrow button pointing toward the Column(s) slot of the dialog box.  Click on the Cells button to display the Crosstabs: Cell Display dialog box.
Step 3:

In the Crosstabs: Cell Display dialog box, select both the Row option and the Column option in the Percentages section.  Then click on the Continue button to return to the Crosstabs dialog box.
Step 4:

In the Crosstabs dialog box, click on the OK button, after which the contingency table is displayed as SPSS output.
Step 5:

Notice that the title of the output is Crosstabs.  Double click on this title to edit it, so that it is in the following format:

Contingency Table for Smoking Habits and Job Type

Text Exercise 8-2

Your Name - Math 123(your section) - Today's Date - Lab #4
When you are finished editing the title, click once in a blank area to leave the title editor.
Step 6:

You may delete each one of text boxes containing a log of the SPSS procedures used, by clicking once to select and pressing the delete key once.  Then, make certain that no item in the output is selected, and use the File> Print options to obtain a printed copy of the contingency table.
Step 7:

Since there is no need for you to save the output, you may close the SPSS output window without saving the results, after you have your printed copy of the output.
4. Create the two possible stacked bar charts, both with bars scaled to a height representing 100%; print a copy of these stacked bar charts.

Step 1:

Select the Graphs> Legacy Dialogs> Bar options to display the Bar Charts dialog box.
Step 2:

In the Bar Charts dialog box, select the Stacked option by clicking on the corresponding picture.  Then, make certain that the option Summaries for groups of cases has been selected, and click on the Define button to display the Define Stacked Bar: Summaries for Groups of Cases dialog box.
Step 3:

In the Define Stacked Bar: Summaries for Groups of Cases dialog box, you should see a list of the variables on the left.  Select Job Type (jobtype), and click on the arrow button pointing toward the Category Axis slot of the dialog box; then select Smoking Habits (smoke), and click on the arrow button pointing toward the Define Stacks by slot of the dialog box.  Make certain that N of cases is selected in the Bars Represent section.  Click on the OK button, after which the graph is displayed as SPSS output.
Step 4:

Notice that the title of the output is Graph.  Double click on this title to edit it, so that it is in the following format:

Stacked Bar Chart for Smoking Habits and Job Type

Text Exercise 8-2

Your Name - Math 123(your section) - Today's Date - Lab #4
When you are finished editing the title, click once in a blank area to leave the title editor.
Step 5:

Double click on the graph in order to display the graph in the SPSS Chart Editor where a graph can be customized.
Step 6:

In the SPSS Chart Editor, select from the main menu the Options> Scale to 100% options.  Notice that the heights of the bars do not change, since the counts were all 100; however, the vertical scale does change to proportions instead of counts.
Step 7:

In the SPSS Chart Editor, single click on the title Count for the vertical axis to select this title.  You should then find that when you move the mouse directly over title text and single click, you will be able to edit the title text.  Change the title to Percent, and select the File> Close options from the menu to close the chart editor.
Step 8:

To create the second stacked bar chart, select the Graphs> Legacy Dialogs> Bar options to display the Bar Charts dialog box.
Step 9:

In the Bar Charts dialog box, make certain that the Stacked option and the Summaries for groups of cases option have both been selected, and click on the Define button to display the Define Stacked Bar: Summaries for Groups of Cases dialog box.
Step 10:

In the Define Stacked Bar: Summaries for Groups of Cases dialog box, you will switch the roles for the two variables; that is, you need to put the variable Smoking Habits (smoke) in the Category Axis slot, and to put the variable Job Type (jobtype) in the Define Stacks by slot.  Make certain that N of cases option is selected in the Bars Represent section.  Click on the OK button, after which the graph is displayed as SPSS output.
Step 11:

Now, repeat steps 4, 5, 6, and 7 (but this time you will notice that the heights of the bars change in step 6, since the counts are different from 100).
Step 12:

You may delete each one of text boxes containing a log of the SPSS procedures used, by clicking once to select and pressing the delete key once.  Then, make certain that no item in the output is selected, and use the File> Print Preview options; you may notice that the second stacked bar chart and its title have been separated.
Step 13:

To fix this, click on the Close button, and click once on the title for the second stacked bar chart to select this title.  Next, select. the Insert> Page Break options.  Once again, make certain that no item in the output is selected.  Use the File> Print options to obtain a printed copy of the stacked bar charts.
Step 14:

Since there is no need for you to save the output, you may close the SPSS output window without saving the results, after you have your printed copy of the output.
5. Exit from SPSS, and use the printed output when doing Text Exercise 8-2.

Step 1:

Exit from SPSS.
Step 2:

Use the printed output when doing Text Exercises 8-2.
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